Home Hobby laser engraver delay on issue with new laser module

Discuss laser machine here freely.

Moderator: baker

Post Reply
ptcruiserx3
Posts: 4
Joined: Thu Jul 09, 2020 1:48 pm

Home Hobby laser engraver delay on issue with new laser module

Post by ptcruiserx3 » Thu Jul 09, 2020 1:52 pm

hi
i have a home hobby GRBL based laser engraving machine..the machine had and has no issues with its original 2w diode laser..it works fine

i decided to add a more powerful 5.5W laser head

i installed the new driver board and laser head and the issue is when a toolpath is started the laser fan powers on instantly at the start of all toolpaths but the laser has about a 3 second delay so i am not able to engrave anyhting due to the delay..the project never comes out correct...once the laser comes on after the delay to do a toolpath it stays on fine and completes the toolpath.....it only has issues at start of all new toolpaths due to the delay on...so if im doing a text engrave when the laser goes from letter to letter it has a delay on at the start of each letter so obviously it doesnt work ....since the machine is moving to the toolpath but the laser is delay on..i have swapped out with a replacement driver board and same issue i also swapped out with a replacement 5.5 laser and same issue

im pulling my hair out trying to find out why this is happening.

here are some pics of my hobby machine

the small laser in the front is the orig 2w laser..it works perfectly fine..the lasrger laser in back is the 5.5w laser that for some reason has delay on

im using same exact software LASERGRBL for both lasers....nothing has changed at all except a diff laser and driver board and have not changed any settings in GRBL or LASERGRBL...

thanks
Attachments
20200709_090211.jpg
20200709_090211.jpg (198.16 KiB) Viewed 793 times
20200709_090205.jpg
20200709_090205.jpg (188.8 KiB) Viewed 793 times
720302.jpg
720302.jpg (161.75 KiB) Viewed 793 times

ptcruiserx3
Posts: 4
Joined: Thu Jul 09, 2020 1:48 pm

Re: Home Hobby laser engraver delay on issue with new laser module

Post by ptcruiserx3 » Fri Jul 10, 2020 2:25 am

I think i may have found issue...it may have something to do with ttl and eiring issue...there were no instructikns with the new laser so i copied same as orig laser but i think is wrong since the laser driver board is diff.

ptcruiserx3
Posts: 4
Joined: Thu Jul 09, 2020 1:48 pm

Re: Home Hobby laser engraver delay on issue with new laser module

Post by ptcruiserx3 » Fri Jul 10, 2020 1:45 pm

Update ..issue fixed..it was user error install

I wired the driver board ttl + to arduino pon d11 and ttl - to arduino gnd pin and now the laser powers on immediately at start of toolpath

There were no instructions with the new laser

However for some reason when i power on the controller board the new laser fan is always on..

With my orig laser and driver the fan only turns on when laser is on.which is how it should be....so with new laser..this is a minor not big deal thing but still odd

ptcruiserx3
Posts: 4
Joined: Thu Jul 09, 2020 1:48 pm

Re: Home Hobby laser engraver delay on issue with new laser module

Post by ptcruiserx3 » Fri Jul 10, 2020 1:47 pm

20200710_093918.jpg
20200710_093918.jpg (200.73 KiB) Viewed 767 times

Post Reply