Red dot pointer not showing on Nova 63

We provide online after sales support here, very quick reply.

Moderators: baker, Thunder Laser -Nolan, Thunder laser - Tom

Forum rules
All members should make themselves familiar with the forum rules. Please ensure you read this section of the forum BEFORE posting.
This sub-forum is only for thunderlaser users ask for tech support from thunderlaser tech persons directly. The normal member should raise your questions in the General Discussion sub-forum. Before ask a new question, please read the "Previously Asked Questions"first to save your time.
Post Reply
User avatar
Posts: 21
Joined: Wed Jul 05, 2017 11:50 am
Location: Romania

Red dot pointer not showing on Nova 63

Post by andaluzia1973 » Fri Apr 06, 2018 4:00 pm


The red dot pointer is supposed to be a standard feature. It has never worked. What should I do to enable it?
Thank you

Posts: 128
Joined: Tue May 24, 2016 9:06 am

Re: Red dot pointer not showing on Nova 63

Post by Ben » Sat Apr 07, 2018 2:26 am

Hi Anda,

I'm sorry to hear that.
The red dot pointer can be adjust from the four screws that holding itself.
Please let me know what do you mean it has never worked.
If it was broken or the alignment of red dot is not good.

Post Reply