Chinese laser y-axis problem after rotary use

General knowledge about laser here.

Moderator: baker

Post Reply
Posts: 4
Joined: Tue Nov 07, 2017 6:06 am

Chinese laser y-axis problem after rotary use

Post by jensenbreck » Mon Apr 02, 2018 8:29 am


Need some help here, i have a chinese laser, using lasercut 5.3, MPC6515, after switching the y-axis to use with the rotary attachment, and switching back after, the y-axis just vibrates like mad when i move it, it seems to have something to do with the laser controller i am not sure. Try all means to reset it but not working, download config but it is still the same, not the first time this is happening, the last time it happened, it stayed that way for a week before magically becoming normal again. Anyone have any ideas ? Or have the some problems?
Please help.

I didn't find the right solution from the Internet.

References: ... 60500.html
ICO Marketing Campaign


Posts: 1
Joined: Sun Mar 25, 2018 2:27 am
Location: Sarasota FL

Re: Chinese laser y-axis problem after rotary use

Post by Frankqv » Tue Apr 03, 2018 3:02 am

Vibration would be from an accel/deceleration setting being incorrect,check with manufacturer for original settings

Posts: 6
Joined: Tue Apr 03, 2018 8:01 am

Re: Chinese laser y-axis problem after rotary use

Post by laserbell » Tue Apr 03, 2018 8:07 am

Try re-seating the cable, then power down. When power is off, try moving the gantry back and forth to make sure that there is no obstruction, like some cable holding it back from proper motion. Then power on and home. If it does not home properly, perhaps the cause is that the firmware got corrupted and that can be caused by plugging in the rotary while the machine is powered on. So, go to your computer and download the "system" file to the control board and listen for the loud single "beep" to indicate that it worked. Then, power off and power on.

Post Reply