User’s Manual ofLaser cut off line control system

Chapter 1 Overview

1.1 Laser engraving cutting system introduction

Laser engraving cutting system through a computer numerical control machine tools to achieve
effective control, according to the user’s different requirements of the completion of processing
tasks.

The system including control board and control panel, and supporting software. This manual
describes how to use the software to complete the task of laser processing.( Motherboard wiring
and control panel operations, see the accompanying manual and control panel wiring board

operating instructions)

1.2 Software supported file formats

Vector format: dxf, ai, plt, dst, dsb...etc.
Bitmap format: bmp,jpg,gif,png,mng,...etc.

1.3 Environmental requirements



(1) Windows XP operating system and above, XP recommended.
(2) Above CPUS586,above PIII or PV recommended.
(3) Memory, above 1G recommended

Chapter 2 Software Basic Operation

2.1 The main interface operation

After start the software, you can see the interface shown in the following figure.
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Menu Bar: The main function of this software are available through the implementation of the

Menu Bar. Execute the menu command is the most basic mode of operation. Menu Bar including:

Document. Edit. Draw. Setting. Processing. View and Help.

System Bar: On the System Bar, placed some most commonly command buttons which is chosen

from the menu.

Graphics Bar: Graphics property bar is the basic attributes of graphics operations, including

graphic location, size, scale, number processing.

Edit Bar: The Edit Bar default on the left of the work area. In the Edit Bar placed frequently used

tools to make the operation more flexible and convenient.

Align Bar: Alignment of the selected objects.

Layer Bar: Change the layer of the selected objects.



Control Panel: Using the Control Panel to complete laser processing of multiple tasks, Layer

parameter settings, axis control, processing ...etc.

2.2 Language settings and manufactures information

In addition to installation process can set the software language type, you can easily switch in
different language.
Click Menu Bar [Help] > [i# 5 /Language] expand menu, select the required language types.
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To obtain manufacturers information,so that we can provide you with better service. Click Menu
Bar [Help] > [About RDCAM]

About tg@

Corp. Name: | """
7 7= [ e
Fax: """
Addr:! """
Web:|******

How to set manufacturers, refer to {RDCAM software installation instructions)
The bottom of the dialog box shows the current software version number. As different versions of
software may be have some differences on the functions and interfaces, you can easily contact and

communicate with manufacturers through software version number.



2.3 Page Setting

Page setting eS8 Click Menu Barl Config]->[ Page setting Jthe following dialog

Page size box appears:
Page width: [1200] mm

ight: 800 . . . .
i " [ Page width]: Software page width, usually associated with
G.:d _ machine X breadth.
(V] GridSpace: 50 mm
[ Page height): Software page height, usually associated with
Keyboard
. machine Y breadth,
Adust distance: 1 mm

Adketiate | 10 Under normal circumstances, if you have connected to

Adust angle: 1 0 the motherboard, software will automatically format for the
= current work of the machine, as a page size.
sadgrownd | If the board is not connected, or need their own custom

workres ||| N page size (such as to set the page size by material), you can

Grid use the page setting to reconfigure the page size.
) [ Grid]
Setting gird space and whether enable grid.

{ Ok ] [ Cancel

[Keyboard]

User can use arrow key to moving or rotating the selected graphics.
[ Color config]

Setting the color of the work area.

2.4 File Open and Save

The software uses rld file format to save graphic information. layer parameters of various layers

and processing sequence of the graphic elements.
2.4.1 Open File

Click menu [File] > [Open] ,or click iconi, the following dialog box appears:

% Open-. S § . =)
EHEE O RDforksVT - 03 E
= : oG £ i
Fonts 2014/5/517:18 =L
temp 2014/5/7 10:09 =
Vendor 2014/5/7 1032 Xz
Xfam: | 7 0)
MBI [xrld - :ﬂliiﬁ
4 LSRR ATH &)

(2) Select file (e.g. Default.rld), click [Open].



2.4.2 Save File

(1) Click menu [File] -> [Savel ,or click iconn,the following dialog box appears:
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[ Default r1d

Input file name

G QD / | #Fe |
{RIFZER (1) |RLaser Files(k.rld) ~| By l

(2) Enter the file name in the edit box, then click [Savel.

2.5 File Import and Export

Because this software is rld format, so to make or edit the use of other materials will be done
by importing. After using the Export to graphic files for other software.
Supported file format for import : dxf, ai, plt, dst, dsb...etc
Supported file format for export: plt

2.5.1 File Import

Click menu [File] -> [Import], or click icon & o The following dialog box appears.
Select file,and click [Openl.
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@ Sclect [Preview], the selected file can be shown.
For most vector file,data automatically imported into the corresponding layer of RDCAM

software according to the layer description.
For some special documents such as DST/DSB, data will be imported into the current layer.
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2.5.2 File export

Click menu [File] -> [Export] or click icon CH - The Export dialog box appears.

Input file name,and click button [Save] .

File Parameter LX)
Import Setting
r -
PLT Precision: L1016 BR ‘

DXF Unit: [D

[] 1mport Dxf text info
Auto dose curves

Close error(mm): 0.1

Combine lines

Combine error(mm): 0.1

Export Setting:
Export Precision(%): 80

Velocity Unit: [mm/s | v |

[ Ok ] [ Cancel ]

2.5.3 File parameters setting

PLT Precision: According to the accuracy of the original
plt file to select the appropriate import unit.

Smooth curves: When import vector file, automatically
smoothing the original curves. For the original graphic is
smooth or need to repeatedly adjust the beset smoothing
effect, you can uncheck this button. Do not do smoothing

curves may reduce time of import processing.

Auto close curves: According to close tolerance automatic check and closed curve

Combine lines: According to merger tolerance, auto-connecting curves.



Color map automatically switch to gray scale: Because under normal circumstances, graphics
are based on gray scale. If the imported bitmap is a color image can be converted to gray scale.

Import Dxf text message: When the user need only Dxf the graphic information, not need the text
information within the file, do not check this.

Export precision: The precision of export plt file or output file.

Velocity unit: Software supported two types of speed unit: mm/s. m/min. Selected according to
usage. After it was selected, the speed of parameters on the interface unit will change with it.

2.6 Basic graphics creation

€ Line

Click menu [ Draw]->[Linel, or click Edit Bar 4 ,drag the mouse on the screen you can draw

an arbitrary line. Press the “Ctrl” key while dragging the mouse to draw horizontal or vertical

line.

@ Poly line

Click menu [Draw] -> [Poly linel, or click Edit Bar - . Drag the mouse on the screen you

can draw an arbitrary poly line.

€ Rectangle

Click menu [Draw] -> [Rectangle], or click Edit Bar = - Drag the mouse on the

screen you can draw an arbitrary size rectangle.

Press the “Ctrl” key while dragging the mouse to draw square.

@ Ellipse

Click menu [Draw] -> [Ellipse), or click Edit Bar » Drag the mouse on the screen

you can draw an arbitrary size ellipse.
Press the “Ctrl” key while dragging the mouse to draw round.

@ Point

Click menul Draw ]->[ Ellipse ], or click Edit Bar * _Click the mouse on the screen, you can draw

an point.

@ Text

Click menu [Draw] -> [ Text), or click Edit Bar A » And then in a drawing area any position

click, pop-up text input dialog box.



Text
@ TrueType font: T Tahoma i Width: 50 %
© stix font: &3 Fs.SHX Char space: 0 mm
Text - Line space: 0O mm
[T Enable variable text
< »
Height: 8 mm [ OK ] [ Cancel ]

Choose font word, input text word, then set high , wide, word spacing, line spacing. Click again
[OK] .

The software also supports variable text, the so-called variable text, the text is need according
to certain rules change, every output processing time, text to be automatic change again. For the
system variables have character type date variables and serial number.

LX)

Text

@) TrueType font: T Tahoma hd Width: 50 %

® X mat: Sl Fs.SHX Char space: 0 mm
Text - Line space: 0 mm

[¥]Enable variable text

[02:32]
[02:32:43]

#H:MM] [14:32]

24Hour [HH:MM] [14:32:43] p
American Date[05/07/2014] =
Chinese Date[201405807H]
Chinese Date Time[20145E058507,
Chinese Time[ 1485 324343%1]
European Date Time[07/05/2014p]
European Date[07.05.2014]

Week Year[07/05/2014 14:32:43] -

Offset: Day ~|0 >

<

Height: 8 mm [ appy | [ oK ] [ concel |

Variable is the date when the current every time processing take the current system of
computer time output. Software offers a variety of date format for customers to choose.
Users can also set the date migration, have the day by the month according to the years 3

kinds.
As in packaging carved on the expiration period can use the product.



Text &3

© TrueType font: T Tahoma v Width: 50 %
St oot il Fs.SHX Char space: 0 mm
Text A Line space; 0 oo Extend &‘
[V]Enable variable text =1
- |Enable reset
Prefix: [¥]Enable prefix ZERO
Suffix:
StartSN: 0000 | Enable SN array
Current SN: 0000 Number Space | | , ] | |
SNInc: 1 s = =)
X: |1 1
Extend =
y: |1 1 ==
Height: 8 mm 1 Apply l ’ oK ] ' Cancel l [ OK ] [ Cancel ]

If ABCOOO1DEF processes repeatedly, ABCOO02DEF, ABCOO3DEF until ABC9999DEF a
group of serial number.

[Prefix] : serial number prefix, example ABC is leading string.

[Suffix] : the serial number of the suffix, example DEF is the string after.

[ Start SN ] : from which a specified number start manufacturing, example is to start to 0001
serial number.

[ Current SN'] : the current processing to which, serial Numbers, can also be used to specify the
current to processing which serial number. As in the processing a group of serial number, leakage
processing the one, but through the designated the current serial number to make processing, not
set start, serial Numbers, because in some cases a group of serial number requires repeated
processing, namely to a serial number, need to go back to the start serial number start
manufacturing.

[ SN Inc] : the interval number can be prescribed sequence number. Example will in turn
processing from 0001 to 9999 serial number, the increment is 1.

If only need to output even or odd number serial number, can set incremental is 2.

[ Enable reset] : when serial number processing to reset the serial number, [current SN1 will
be automatically reset to  [start SN .

Example requires repeated processing from 0001 to 9999, serial Numbers, so can be
designated 9999 as reset, serial Numbers, when processing the 9999 serial number, text will
automatically change to 0001.

[ Enable prefix ZERO] : if not lead to zero, the system will automatically remove the first in
the serial number of zero digital before the zero. Such as the example, serial Numbers, if not the
leader's zero can ABCOOO1DEF will become ABC1DEF. But it is worth noting that, if we want to
output serial number is ABC1DEF, ABC2DEF until ABC9999DEF, we can't through the will

[start SN] set to 1 to achieve, but through the cancel [ Enable prefix ZERO] to achieve, this
is because set in the specified number from the start the serial number which one, beginning
outside, also specifies the number of significant digits, such as will begin to serial number set to 1,
the change of the serial number order is: 1,2,3,4,5,6,7,8,9,0,1,2,3,4,5... Serial number won't change

to 10, because the effective a serial number had 1.



[ Enable SN array ] to the array of way, one-time processing more serial number.
for instance:
0001 0002 0003 after this batch processing serial number, 00150014 0013

0006 0005 0004 skip directly to the next group of 0007 0008 0009
0016 0017 0018 0016 0017 0018
€ Capture

Click menu [Draw] -> [Capturel, or click Edit Bar 4
ReAE ki 3

EE 1.0 (32-32) |

If the computer has been connected to the image device, the dialog box will appear. After it
was selected, you can collect the pictures from the specified device.

2.7 Object Selection

In the process of drawing and edit graphics,first of all is to select the object.

b3

When the object is being selected,in the center of this object will have a shaped mark™ x ”, and
surrounded by eight control points.

Click menu [Draw] -> [ Select), or click Edit Bar % , switch to status“Select”. Under this

status,you can select object.The following are five kinds of method of selecting:
€ Click menu [Edit] -> [Select All] (Shortcuts Ctrl+A) , select all objects.

€ Click mouse on the screen to select single object

{

ag
4

00



@ Select object using select box

Press the mouse and drag, as long as the box come into contact with the object will be selected.

@ Increased select object/minus select object

Increase select: Press “Shift” key, click or box select to increase select object.

Minus select: Press “Shift” key, click or box select the selected object.

@ Sclect object according to layer

Work iOutput l Doc l User I Test [ Transform]

Layer Mode Speed Power OQutput
B 100.000 30.000 Yes
B ot 100.000 30.000 Yes

Cut 100.000 30.000 Yes
B ot 100.000 30.000 Yes
B ot 100.000 30.000 Yes
B ot 100.000 30.000 Yes

( Up ] [ Down ]

Right-click the selected layer, then the part of all objects in the layer will be selected.

2.8 Object Color

The color of object that is the color of the object contour.You can click the color button on the
Layer Bar to change the color of the object has been selected.The color of the pressed button is the

color of current layer.

2.9 Object Transformation

Transformation of object mainly include: object location . orientation and size. But does not
change the basic shape of the object and its characteristics.

Transformation of object for users, provides a convenient user interface. User can mirror
= OO 1+
M=sEBED
You can also use the Object Properties toolbar

% (44591 |mm 4 (235989 | mm | (100 | oo ,
¥ 209,208 |mm § |208.549 | mm | (100 | e n LR ProcessNOrlL

within the draw toolbar.

and rotation through

You can also use the right transformation tools to transform and copy the graphics.



X
IWork IOutputlDoc Iuser ITest ]Transf'orm L

[+ o]

Position:

Horizontal(H) 394734  mm

Vertical(V) 606.812  mm

["|Relative position
B-EB-7
B e B
A-E-T

[ Apply to copy ]

| Apply |

2.9.1 Object Image

Object image is flip the selected object in the horizontal or vertical direction.

Click Edit Bar 2& | flip the selected object horizontal.

3

Click Edit Bar ™ , flip the selected object vertical.

X
| work | Output | Doc | user | Test ITransformL

+ of[F
Ratio: ntal(H) %
tical(V) 100 o
Mirror
0 | =
["| pisproportionate
B E— j
B e O
f-B-1
[ Apply to copy ]
[ Apply |

Or through the mirror to the transformation tools, horizontal and vertical mirror, and copy.



2.9.2 Object Rotate

Click Edit Bar ) » will pop up the dialog of rotate angel setting.
Set rotate angle and click the button [OK] .

Rotate &

Rotate angle(deg) D!

[ Ok ] [ Cancel ]

If you want to drag rotation, set rotate angle 0,and determine.
Dragging the mouse to adjust the rotate angle, in the dragging process, there will be followed by

rotating wire-frame outline.

7“['\"\' =

:

X ¥ [235.989| 100 | o
¥ 2$ sl o ; E @] (v o |° Pprocessno:t |

208.549 | mm | [100 | %

Or directly enter the rotation angle in the Object Properties toolbar.

4 X

[work [output [Doc  [user [Test | Transform |

+ [ <] & 2
Rotate: Angle 0 5
Center:

Horizontal(H) 544.734  mm
Vertical(V) 606.812 mm

["]Lock rotate center
[T]Rrelative center
BE_E_E
B © B
B-B-8
[ Apply to copy ]
[ Apply |

Or use the spin rotation transformation tools to transform. In the rotations transformation tool can

be set to the center of rotation and locking center of rotation.



2.9.3 Object Size

X (445.91 |mm ¥ (235.989 | mm | [100 | o % 0 ,
¥ (255 505]mn Blllz0s.545]mn | (100 ] G b__]° Pocessnoift ]

You can set size and center position of the selected object.

x

[Work IOutput[Doc ]User |Test | Transform L

+| G| £

Size:
Horizontal(H) ©645.611  mm
Vertical(V) 173.819 mm

[ | Disproportionate
80T
5 e B
B-m-1
[ Apply to copy ]
| Apply |

Or use the size transformation toolbar to change the size of object. Can modify the size, choose

whether to lock the aspect ratio, and set the position relative to the object to transform.



2.9.4 Tilt

4 X
T

| Work | Output | Doc | user [ Test | Transform |

+ o] €| &z
Skew:
Horizontal(H) © Deg
Vertical(V) 0 Deg
["] Use anchor point
[ Apply to copy |
[ Apply ]

Object can be tilted by the tilting transformation tools. It can be set the tilt anchor and the tilt
angle.
The tilt will cause distortion of the bitmap and the practical application of small, currently only

supports the tilt vector graphics.

2.9.5 Object Array Replication

oo
Click Edit Bar % , select object wants to copy. Then click OO, the following dialog box

appears:
Array copy @
XNum: 1 XSpace: 0.000 Goh
YNum: 1 YSpace: 0.000
...
[ Ok ] [ Cancel ]
Width of a single graphic(mm) Height of a single graphic(mm)

You can array replication object along different directions.The direction of copy is based on the
original graphics.Such as choose the array direction lower right,then the original graphic will
appear on the upper left corner.wheres if it is to the upper left array,then the original graph appears
in the lower right.



After setting the array number and array spacing, click button [ Apply] ,you can see the actual
graphics
array.
There are two forms of array spacing: center spacing and edge spacing.
Choose center spacing, then [X Distance(mm)). ['Y Distance(mm)] representing the distance of
the two graphic center.
If not choose center spacing,then [X Distance(mm)).['Y Distance(mm) Jrepresenting the distance
of the graphic edge.

Center distance X = Edge distance X + width of object

Center distance Y = Edge distance Y + height of object

Switch between the two kinds of calculate method, [X Distance(mm) ). ['Y Distance(mm) ) will
be calculated automatically.
Click [Bestrewing breadth], The software will automatically calculate the array number
according to the workpiece six. width. height. X distance and Y distance.
Adjust spacing can be directly input values,and click [ Apply]
Can also press the diction keys to adjust objects spacing.
Check [Center] ,then after object array replication,graphics will be centered on the work area.
Scroll the mouse wheel to zoom view of the graphics.
Drag the mouse to pan view of the graphics.

2.9.6 Place Object To The Origin

Place the object is to facilitate the view or orientation. The following tools are provided by

software:

+
, selected object will be placed in the center of the page, that is the object center

coincides with the center of the page.
K 71N e

lower left, upper left corner of the object, upper right, lower right, lower left and upper left corner,

, Selected object will be placed on the page left, upper right, lower right,

top right, bottom right, bottom left corner of coincidence.

2.10 Object Align

Select objects ) click tools on the Align
L RERN 20 H S DB
Whick include:

o O
2 & 0w Left alignment. Right alignment. Top alignment. Bottom alignment



mnA C3 [M
(=) LJ . . . . .
v <> L Vertical center alignment. Horizontal center alignment. center alignment

I-E 75

Horizontal equidistance. Vertical equidistance

=0 =

Same width. Same height. Same size.

Benchmark object:

If you press “Shift’key and select object one by one,then the benchmark object is the last object.

If you select object by select box,then benchmark object is the object which curve number in the
final.

2.11 Object View

+
Move: Click menu [Edit] -> [Movel, orclick “. Then hold down the left mouse button in

the drawing area, and drag pan.

Zoom Out: Click menu [Edit] -> [ Zoom Out]), or click R, Each click it, the drawing area

zoom out once.Move mouse to the drawing area and click,each click,mouse position as center

drawing area zoom out once.

Zoom In: Click menu [Edit] > [ Zoom In], orclick . Each click it, the drawing area zoom

in once.Move mouse to the drawing area and click,each click,mouse position as center drawing
area zoom in once .

. . . . . o .
View Select: Click menu [Edit] ->['View Select], or click ~*. Move the mouse to the drawing

area,hold down the left mouse button and drag, a dash border box will show in the drawing
area,release mouse button, then the region in the dash border box will display in the drawing area
with the largest proportion.

View Page Frame: Click menu [Edit]->[View Page Framel, or click B, The page frame will

full display.

View Data Frame: Click menu [Edit] -> [ View Data Frame], or click *, The selected objects

will full display

2.12 Group and Un Group

Edit graphics, and sometimes need to be a part of the operation as a whole (such as multi-line
text layout).
Method: Select the group of graphics, and then select the menu [Edit] / [Group] ( [Un

Group] ), or directly select the toolbar o |



2.13 Important Tool

Here are some frequently used tools. Using these important tools, can make the current
document in the graphics more orderly, and make the processing of output more fast.

2.13.1 Manual sorting and the set of cutting point and the cutting direction

Software provides users a convenient tool for the manual sorting. Select [Edit] -> [ Set
cutting property ]. Cutting property dialog box will pop up. All with manual sorting, and cut points,
cutting the direction of the settings in this dialog box can be completed.

Rl tiag propery - 2 85 5 & = 8 = % s 28> . = _—
[ ReOrder J L Reverse ] [ ReOrder ]
------ S, e e e e R e e e e e e e me P e e S s e s o ] NO Name NO Name
1 Element1
e 2 Element2
% 3 Element3
4 Element4
N—— S s g e o e R 5 Element5
! 6 Elements
: 7 Element7
v 3 Elements
E 9 Element9
10 Element10
...... B Sl S i S I e S S e SRR e 11 Element11
12 Element12
13 Element13
& 14 Element14
15 Element15
16 Element16 >>>
5 Sl (2 It e b et g 17 Element17
: 18 Element13
19 Element19
\:f 20 Element20
21 Element21
______ S e e e A S 22 Element22
23 Element23
24 Element24
25 Element25
[¥] showPath 1] LI
XS

Show path
First check the “show path”, it will display the current graphics cutting order and the cutting

direction.
Manual sort

Select @ This button is used to switch the current status of the operation is to edit or view.

Then you can marquee or click the graphics in the graphics display area (or click one pixel or



another list, to be processed as the first primitive. Primitives followed by repeated operations, to

check many pixels). After selecting the graphic, select , these graphics to be redirected to

complete sequencing of all graphics.
Change the direction of graphic processing

Mouse select the graphic in the graphics display area or in the list. And then click .

Change the cutting point

Set cutting property @

[ ReOrder H Reverse ][ ReOrder ]

NO MName A NO MName

Element1

Element2
Element3
Element4
ElementS
Elementé
Element7
Elementd
9 Elementd
10 Element10
11 Element11
12 Element12
13 Element13
14 Element14
15 Element15
16 Element16
17 Element17
18 Element18
19 Element19
20 Element20
21 Element21
22 Element22 < < <]
23 Element23

24 Element24

25 Element2s
26 Element26

27 Element27

28 Element2a

29 Element29

30 Element30 ¥

|

WA N

.ShowPath A _ﬂ'_] M A

Select the graphics that should be changed the cutting point, it will show all the nodes in the

current graphics. Select the starting point, double-click the mouse, it will change the starting point

of the current graphics. After the completion of all changes, click , the result of the

changes can be saved.
In addition to cutting property features, the software also offers some tools to change the

cutting order, cutting direction and cutting point.

Select ’Q in the toolbar, or click the menu command [Edit] -> [ Show Path] .
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Manual sort
Choose the primitive that should be changed the cutting order, then the cutting serial number of

the current primitive will display in the object properties bar.
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Enter the serial number directly in the processing number, then press the keyboard “Enter
key, or click the plot area, the cutting order will be changed.

Change the processing direction
Click [Edit)] -> [ Set cut direction] , to enter the edit mode of the cutting direction. Then you can
double-click on any position on the selected graphic.

Change the cutting point
Click [Edit]->[Set cut point], to enter the edit mode of the cutting point. Then select the curve

that should be edited, you can double-click on the node that you want to set the cutting point to
complete the change of the cutting point.



2.13.2 Setting And Editing The Cut In/Cut Out Lines

% Default -
File(F) Edit(E) Draw(D) Config(S) Handle(W) View(V) Help(H)

DEPH 2T 00 AaQQAQAQARQ[ B o #|~/wdaibbad |l %%
pommmm e m 2 v @E 00 ° comemno 1| [outmod o) e ] cutinou fene[orew] | Flenabeinkres—

O T P P I T I P I T T

3 =

Figure 4-1 metal cutting process menu

Inner mod/outer mod:
Inner mod refers to that inside of the graph unit is waste, and outside part of the graph unit is for

process components. Graphics must be selected before perform this operation.

Automatically:
Automatic button is to set the inner mod and outer mod automatically. The software consider that
the innermost curve unit is outer mod, then inner mod. The independent curve unit is outer mod in

default. Graphics must be selected before perform this operation.

Drawing or importing curves, the curve is default not have any cut in/cut out lines.
If want to add cut in/cut out lines,select the objects, then click [ Edit] -> [ Edit cut in

property ], or click ® .The following dialog box is appear.
Cut in and out setting (S|

Cutin
["]Enable
Length(mm): | °
Angle(degree):| 7
Cut out
["]Enable
Length(mm): 5
Angle(degree): 45

[ Ok ][ Cancel ]

To make cut in/cut out lines, first of all need to enable the cut-in/cut out function.

There are two types of the cut in/cut out lines: straight line and arc

Straight line cut in achieve through three ways:

Cut in with angle: cut in line and starting segment into a certain angle, counterclockwise angle is
positive

Cut in at center, the starting point of the cut in line is at center.

Cut in from center, the direction of the cut in line is from center to starting point, and length is as

setting.



Cut out line

Cut in line -

The arc length of cut in arc is as setting.
There are two types of cut in/cut out arc, as shown in the following figure

Female Male

The processing of setting cut out lines is same as cut in lines.
2.13.3 Path Optimization

Path optimization is primarily to re-order the vector graphics.

o
Click menu [Handle] -> [Cut optimize], or click ® % the following dialog box is appears.

Cutting optimize handle (S|

["] Order of layer

[V] Inside to outside
[Single inner to outer v]
Block handle
Height: 50 Dir: |Up to bott ¥
["] start paint optimize

[V] Auto determine start point and direction

[ Ok ] [ Cancel ]

Click menu [Edit] -> [ Show Path], or click 0 , can see the cutting path before and after

processing.
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Before processing After processing

Graphics cutting path is always starting from the laser head.

2.13.4 Curve Smooth

For some less accuracy curves, this function can make curves more smoothness, and processing

smoother.

Click menu [Handle] - [Curve Smooth], orclick #~, the following dialog box appears.

Curves smooth @

Smoothness ] 95%  [Jpirect smaoth

I l [ Apply “FullFrame][ Ok ][ Cancel ]

Drag the smooth slider, and click button [ Applyl, before smooth and after smooth curves will all

show in the dialog.
The black curves represent the original curves, and the red curves represent after smooth curves.



Curves smooth @

Smoothness J 95% |:] Direct smooth

| I [ Apply ][FuIIFrameH Ok ][ Cancel ]

You can view the graphics with drag mouse.
You can zoom in/zoom out the graphics with scroll wheel.
Click button [Full Frame], graphics will shown in the dialog box for largest.
After get satisfied smoothing effect, click button [ Apply 1, curves will processing smooth
according to smoothness settings.
Select “Direct smooth” , you can use another smoothing method.
The choice of smoothing method should be changed with the needs of the actual graphic.

2.13.5 Check Closure

M

Click menu [Handle] -> [ Curve auto closel, or click System Bar ' ,the following dialog box

appears.

Setting close error A

Close error{mm): 0. 1]

[T Force to close

[ Ok ] [ Cancel ]

Close error: When distance from the starting point to ending point less than close tolerance,
automatic closing of the curve.
Force to close: Mandatory closure of all selected curves.



2.13.6 Remove The Overlap

Click menu [Handle] -> [Delete overlap] ,or click = , the dialog box appear.

Delete overlap lines (S|

[ Enable Overlap error

Overlap error(mm): |2-901

[ Ok ] [ Cancel ]

Under normal circumstances do not select the “Enable Overlap error”. Removing the overlapping
lines when two lines are compared to a good degree of coincidence. If you need to delete
overlapping lines, you should select “Enable Overlap error”, and set overlap error. Generally do

not overlap error set too large, so as to avoid accidental deletion.

2.13.7 Combine Curve

)
Click menu [Handle] / [Combine Curvel, or click =t ,the following dialog box appears.

Setting combine error |t

Combine error(mm): 1

[ Ok ] [ Cancel ]

The software automatically merge curves in the selected curves, when these curves merge
tolerance is less than the setting of combine error.

2.13.8 Bitmap Handle

Click k , and select a bitmap, then click menu [ Handle ] -> [ Bitmap handle], or click System

BMP
Bar .



Bitmap handle

Width: 500 Pixels
Height: 750 Pixels
H Resolution: 96 Pixelsfinch
V Resolution: 96 Pixelsfinch
Brightness: 0.0%
3
Contrast: 0.0%
.
[Jinvert color
[[]set output resolution

Resolution(pixelsfinch)

[CIoither

Dot ara

Sharpen

[ Apply to view J I Apply ta source ]

[ Get outline ]

I |[Save as ”FulIScreenH Ok “ Cancel ]

In the top right of the dialog box displays the information of the current image.
Be noted that, the horizontal resolution and vertical resolution is changing with drag scaling.

[ Apply to view ]: Current settings is only used for preview, without affecting to the original
bitmap, press button [ Cancell, bitmap will returned to the state of original image. Therefore, only
use for adjust effect. However, this approach requires more time and memory Space.

[ Apply to source J: Current settings is use for original bitmap directly, so even finally click
button [Cancell, image will also unable to return to the original image. Therefore, it mainly used
in multi-step operation, and the current operation of this step is necessary to do, such as general
pictures must be transformed into gray scale. This can save the computing time of the follow-up
operation.

[ Save as]: Retain the results of the previous operation, In addition to using [ Apply to view] can
also be exported. On this basic, to facilitate subsequent processing.

[ Gray scale] Generally, other image processing is based on the gray scale, so before handling,
you can do a gray scale processing, then click button [ Apply to source]. For the gray scale than
the color image occupied smaller memory, for large image step by step handle, to a certain extent
to avoid the lack of memory.

For color image, adjust contrast and brightness, have some auxiliary effect to following dither

processing.

Adjust contrast:



Before processing After processing

Invert:

Before processing After processing

Sharp:

Before processing After processing



There are three method for dither processing: Net graphic. Dot graphic. Black and white

Net graphic

Net graphic need adjust net size, better suited to material which is not high resolution, or the laser
is relatively slow to respond.

To get the appropriate net size, you can adjust resolution and net frequency of the image.

The higher resolution, the more delicate.

The higher net frequency,the smaller net size.The lower net frequency, the bigger net size.
Generally, resolution of image is 500 - 1000, and net frequency is 30-40lines.
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Dot graphic
Dot graphic performance of good gray scale, better suited to material which is high resolution, and
the laser responds fast.

Black and white
In most cases, the effects of color image into black and white image is poor,, however, for some

clear outline image, is very easy to use.



RuiDa ACS| RuiDa ACS

Get outline:

Bit handl

[ - 58 488 « 1 mi8Y S i
Width: 379 Pixels
Height: 379 Pixels

H Resolution: 1000 Pixelsfinch
V Resolution: 1000 Pixelsfinch

Brightness: 0.0%

0
Contrast: 0.0%
: 0

[ invert color

[T set output resolution
Resolution(pixels/inch) | 1000

[~ pither

Net graphic

Frequency(lin

Dot graphic
Black And White
@) Gray scale

Sharpen

[ Apply to view I [ Apply to source ]

[ Get outline ]

[ | |[ Fosaeen |[ saveas | ok [ cencel |

Click “Get outline” button to extract the contour graph. As following picture
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2.13.9 Processing preview

Click menu [Edit] -> [Preview] , or click System Bar 2
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Simulate 0]

Software supports the preview of the documents to be processed, and you can get some basic
information through the preview. For example, the path of the actual output of the processing,
general processing time, processing the distance. The machining process can be simulated.

In addition to the current edited file preview, you can also preview the files have been saved
as rd.

Preview rd file:
Double-click in the graphics display area. Choose the graphic you want to preview in the pop-up
dialog box. And then open
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Software also supports to set the parameters of preview

Right-click Anywhere in the graphics display area, the configuration menu will appears.
Select “Config” , pop-up following dialog box

Full window Configuration @
Config

Background
Horizontal mirror Back color: . Font color: .
Vertical mirror Draw color{Power)

on || [ W oo
Simulate color{Power)

oo [ O W o
Idle color .

Anchor

(O Top left (O Top right
() Bottom left (O Bottom right

You can preview the color of graphics to match the actual output of energy. Users can easily
view whether the layer energy is true.

2.13.10 Data check

Selected to check after the graphics, click on the menu commandsl Handle J/[ data check 1},

or click system toolbar lz] .



Data check X

—— = E .
Close check end
Check dose
. Not find unclose curves
[] Auto close Error(mm): |0.01 Self-cross check end
Not find self-cross curves
[V] Check self-cross Cross check end
Not find cross curves
[V] Check cross Overlap check end
Not find overlap lines
[¥] check overlap
["]Enable error Error(mm): | 0.01 [ g

Data check, integration of the closed inspection, the inspection, the inspection, the
intersection of the fellowship data overlap a check. The user can select a check, inspection to the
problem after data, will be in the dialog box right tip have been found and, at the same time, the
problem in selected state graphics. Check-> ruled out repeatedly error-> inspection process until
all the data are conform to the requirements of the processing.

2.13.11 Generation parallel lines

Selected to create parallel lines after the data, click on the menu commands the [Handle] /

[ Offset poly] , or click system toolbar S .

Offset poly et S|

Offset(mm): O mm [IDelete artwork
@ In ) Out (7) Auto InfOut
[ Ok ] [ Cancel ]

Red line in the figure for the original graphics, green line is inside shrink graphics.

2.13.12 LGP design

Click the menu commands the [edit] /[LGP design 1 , or click drawing toolbar, already can
start reflex block design tools, the tools are specific to block the sun processing, is an independent
functions, such as the user is not involved in the sun block can be ignored this section processing

content.



Play channel tabula ras design tools, we first need to design a reflex guide the outline.Play channel
tabula ras design tools, we first need to design a reflex guide the out lin

Play channel tabula ras design tools, we first need to design a reflex guide the outline.

In the tool, the default created a 200 X200 rectangular guide tabula ras outline. The user can in the
tools of "system" page manually create a standard to the shape of the guide tabula ras outline.
Create standard setting the outline can use rectangular or oval.

The user can also import a has good graphic design, as the outline of the sun. Click on the
"introduction to guide tabula ras contour" button, can choose to have the outline of the document
as the sun. Need to point out that outline file must be closed graphics, otherwise, the system will

automatically deleted.
wopcroscan ser R . =

Apply.

Height: 200.0

Elipse

Apply.

Enable LGP blank

Distance: mm

Import artwork

\ P

st <) seaun

LGP Size{mm):

Width: 200.000 Height: 200.000

V| Lock ratio
Apply
Create LGP outline
Width: 200.0 Height: 200.0
Create LGP outline ) Rectangle Ellipse
Height: 200.0 ‘ Apply
9 Rectangle Ellipse Enable LGP blank Combine crossing out
’ Apply ’ Distance: | 0.000 mm
‘ Import artwork ‘ ’

Import artwork |

If the outline of import size requirements, users can also change size outline, and can set up if stay
white edge.
Outline graphics ready, they can start on the tabula ras increase network.



LGP Point{mm)

LGP type: Grid v|

Width; | 1.0000 Height: | 1.0000

UpGrad: | 0. UpGrad: |(
DownGrad: | 0. DownGrad: |
LeftGrad: |0 LeftGrad:
RightGrad: RightGrad: | 0.
Space(mm)

Up: 2.0000 Grad: 0.2000

Down: 2.0000 Grad: 0.2000

Left: 2.0000 Grad: 0.2000

Right: 2.0000 Grad: 0.2000
Base line

X: 0.000 [Zero Y: 0.000 Zeroj

Enable row and colown

EnRow EnColumn
Light source
Left [ |Right
Top Bottom
Apply

Network is divided into six ways: horizontal,vertical line, elliptical, rectangle,reticle and the grid.
Baseline related with light source, the user can adjust the baseline position according to time light
source. In the figure above red graticule marker is the baseline, users can move the mouse to
baseline, press the mouse, and then drag the baseline to want to position.

The entire guide baseline reflex is divided into four regions, level above baseline definition
for uplink and downlink below defined as; Vertical baseline definition for the left column on the
left, the right to define right column.

Set respectively size and spacing network respectively in up, down, left column, the right
column initial value and the gradient of the change, can form users want to conducting tabula ras
effect.

For grid way, must set exercise can/column that can, can appear the grid.

For the convenience of application, the system to provide the light setup, if the light source is
a standard, can choose the light source, then set the network parameters can be, do not need to
adjust the baseline. At this time, baseline shows hides also.

Elliptic way

Grid way




Reticle way Rectangle way

Reticle way Rectangle way

Horizontal line Vertical line



Left light source

Right light source

LGP cutfEngrave
Speed(mmjs); |100-0
MinPower(%): |30.0

MaxPower(%): [30.0

[ 15 blower on
Scan precision [1016
OnDelay: |0.000
OffDelay: |0.000

Outline cut
[JEnable outline cutting
Speed(mmjs):

MinPower(%):

MaxPower(%):

OnDelay:
OffDelay:

Array parameters

[Jefault
[JDefault

ms

ms

ms

® Mum; |1 X Space: |0.000

¥ hum: |1 ¥ Space: |0.000

dpi

( UsB:Auto

J

Position: Current Position

v

(

Start | [PausefContinue |

Stop

]

(

saveUFie ][ outputuFie ][ Download

]

(

Goscale | cutscale

I

Preview

]

Top Light source Bottom light source

Horizontal,vertical line, elliptical, rectangular way is the network scanning
mode of output.

Scanning mode, the minimum energy, maximum energy general is same,
and dedication of the delay is 0. By adjusting the scanning system precision,
to adjust the scanning of the density, the more accurately the scanning scan
line secret, scanning the lower accuracy the scan lines sparse.

The grid processing methods is cutting, and scanning not precision, and
can be adjusted according to the actual effect, the maximum and minimum
energy energy light switch delay, generally speaking, the least energy slightly
lower than the maximum energy.

If need to cut the reflex the outline, make can contour cutting. About
cutting parameters and common cutting Settings identical, in hereby here.



If need to press array in the way processing more panels, can be set to array parameters; Array

direction along the machine is always the origin in the opposite direction.

Chapter 3 System Settings

Before output graphics, required to determine whether the system settings are correct.Click menu
[ Config] -> [System Setting]

Config(s) | Handie(w)  View(y’

Systern Setting

File Para Setting

Page Setting
Password Setting ]

Graph Hatch
Showe Array !
Show grid

3.1General settings

Setting
General settings | System Info

Axis Mirror Laser head

Axis X Mirror ® ® @

[¥] Axis ¥ Mirror ® ©® © [ Absolute coordinate

[] small circle speed limit [T Scanning(Reverse interval
Diameter(mm) Speed(mm/s) Speed(mm/s) Reverse interva...
1100 | 25000 |
2.100 35.000
3.100 40.000
4,100 45.000
5.100 50.000
6.100 55.000
< | 1 | » < 1 | »

Add... Delete Add... Del




Axis Mirror

Generally, Axis direction of mirror is based on the actual location of the limit or home of
machine.

The default coordinate system if Descartes coordinate system, and zero in the bottom left.

If the zero point of the machine is top left, then X-Axis do not need to mirror, but Y-Axis
need to mirror.

If the zero point of the machine is top right, then both X-Axis and Y-Axis are all need to
mirror.

In addition, this function can also use to other application for mirror.

b Default - L=
File(F) Edit(E) Draw(D) Config(S) Handle(W) View(V) Help(H)

DpHEFo0oacaaaaqoes v wmsHHaBD W %%
(584,373 mm Hsa:}w mm | (100 | % aﬁ‘ oo o e o Auto || Cutin/out ‘ Enable fink near
L PRI AN B

¥ [400.858) mm 62 m (100 | %
L T O P R e I I A d

N - | work [output [Doc [ user | Test | Transform|
B Layer Mode  Speed  Power  Output
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K =] Num space Dislocation

g x: (1 0.000 0.000
@ ] Y: |1 0.000 0.000
%
] Bestrew...
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Laser head
Position of Laser head means the location laser head relative to the graphic.
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when you intuitive view, just look at the zone where the green point appears.

Double automatic typesetting

Machine has two laser, check the double spacing, and set the distance, the machine will



automatically adjust the position of the laser
Small Circle Speed Limit
On processing work, the software automatically determine whether the current round need to limit
speed ,then according to the diameter size of the circle to determine the speed. If parameter
configuration appropriate ,will greatly enhance the quality of small round. Click button [ Add],
[Delete] , [Modify] to configuration.

Small circle is less than speed of the rules limiting the list of small round circle of minimum
radius, minimum radius circle at the speed of the output of the corresponding.

If the speed greater than maximum speed limit list the speed round, the speed only associated
with the speed of the layer.

If the speed is in the list, set the output speed by list.

If the request received by limiting layer parameters faster than the speed set in the layer, press
the speed of the output layer.
Scan backlash

Laser scanning graphic way, because the relationship between the machine belt tension may
cause the edge of the scanned graphics uneven. Therefore, increasing backlash to fix. It has the
specific backlash for the certain speed. General, the greater the speed, the greater the backlash.
(D Add backlash

Click the Add button, the screen will pop up as shown in Figure

Scanning(Reverse interval) @

Speed(mm/s) 1

Reverse interval(mm) 0

Ok ] [ Cancel

Set speed and backlash, click OK, the value to be inserted into the list of backlash.
2 Modify backlash
Double-click the left mouse button scanning (reverse gap) need to modify the reverse block

entry clearance, then the pop-up screen shown in Figure.

Scanning(Reverse interval) ﬁ

Speed(mm/s) 25|

Reverse interval(mm) 54

Ok I [ Cancel

In the interface can modify the current speed of the corresponding backlash.

(3 Remove backlash



Right-click scanning (reverse gap) block in the backlash to delete the item, then click the
[ Delete] button.

3.2 System info

Setting

General settings | System Info

Vendor password:

Mainboard version:

Read

ie
TR

Information on the operation of the motherboard manufacturers need to enter password to view

parameters.

Setting
Syaten nfo

Total on time(hour:min:s):

Total processing time(hour:min:s):

Previous processing time(hour:min:s:ms):
Total laser on time(hour:min:s):

Total processing times:

X Total traval(m):

Y Total travel(m):

Mainboard version:

ade

g

H
(]




Total on time: The total time of motherboard working

Total processing time: The total time of processing ,including the time of jump moving.

Previous processing time: The time of the last processing

Total laser on time: The time of the laser processing

Total processing times: The number of completed processing, not include the processing forcing to
end.

X total travel: The total travel of motor X.

Y total travel: The total travel of motor Y.

Motherboard version: The version of the current controller.

The function of upgrades:

If the board has additional features, the manufacturers will provide the update file  (*. bin
format), the user can load the upgrade file to upgrade the motherboard. After the upgrade, you
need to click on the control panel "Reset" button reset the motherboard before normal use.

3.3 User parameters

| Work I Output I Doc | User \Test [ Transform]

==l Cut parameters

Idle speed{mmjs) 200.000

Idle Acc(mm/s2) 3000.000 L
Start speed(mmy/s) 20.000 F
Min Acc(mmyfs2) 400,000

Mayx Acc(mmjfs2) 3000.000
Cutting mode Norrnal Cutting
Acc Mode S mode

= sweep parameters
% Start Speed(mm/s) 10.000
y Start Speed(mmjs) 10.000
¥ Acc(mmfs2) 10000.000
y Accimmjfs2) 3000.000

Lirmm Chift Crnand fraraicY 100 0NN

Open Save Read Nrite

Reading the board parameters must before operating the user parameters.




3.3.1 Cut parameters

B cut parameters
Idle speed{mm/s) 200,000
Idle Acc(mm/fs2) 3000.000
Start speed(mmy/s) 20.000
Min Acc{rmmj/s2) 400,000
Max Acc(rmm,s2) 3000.000
Cutting rmode MNorral Cutting
Acc Mode S mode

Idle speed: this parameter decides the max. speed of all lines not emitting beams during the
operation of the machine. This parameter should not be lower than the lower of the jump-off speed
of the X-axis and that of the Y-axis and not exceed the higher of the max. speed of the X-axis and
that of the Y-axis, if the setting is illegal, the controller will automatically set this parameter within
the range above; a comparatively high idling speed can shorten the operation time of the entire
figure while excessively high idling speed may cause dithering of the tracks, therefore, you should
take all relevant factors into consideration when setting.

Idle Acc: Corresponds to the acceleration of the speed of air travel time, air and air-way-way
speed of acceleration to match, if you set too slow the actual speed may not reach the air-way set
value, if set too fast, they may not withstand the mechanical structure, resulting jitter . Slightly
higher than the general acceleration of air-way cut acceleration.

Cutting Acc: Corresponding to the acceleration of the speed of cutting (cutting speed is the speed
of the layer parameters of the layers).

Turning speed: Turning the corresponding deceleration in the cutting process, the minimum speed
of the drop, when processing a lot of teeth when the graphics may be appropriate to reduce the
turning speed.

Turning Acc: Should match with the turning velocity.

Cutting mode: Split precision cutting, fast cutting, ultra-fast cutting, the user can choose according
to the actual applications. Such as the emphasis on accuracy, select the precision cutting, such as
emphasizing speed, select the fast cutting.

Acc. mode: this parameter decides the acceleration and deceleration mode (S mode or T mode) of
the motor during operation, the motor accelerates and decelerates slowly and smoothly in the S

mode and fast and relatively unsmooth in the T mode; the default mode is the S mode.



3.3.2 Sweep parameters

H sweep parameters
¥ Start Speed(mm/s) 10.000
y Start Speed(mm/s) 10.000

¥ Acc(mmyfs2) 10000.000

y Acc(mmyfs2) 3000.000
Line Shift Speed (mmjfs) 100.000

Scan Mode Cornrnon Mode

Facula Size(50~99%) 80.000

x Start Speed, y Start Speed: Off scanning speed in the use of stepper motor drag, do not
began to accelerate from 0, but can start work directly from a speed to shorten the overall
processing time, but the speed is not too high, and because the X, Y axial load is different from the
rate, general the initial speed of X-axis slightly higher than the initial speed of Y-axis

x Acc, y Acc: With the scanning speed (the speed of layers in the layer parameters) to match,
if set too small, the scan speed to a longer distance, the scanning efficiency. The machine can be
set according to the actual structure, load conditions vary. Since X, Y axis load, generally much
higher than the X-axis Y-axis accelerometer.

Line shift speed of scanning: this parameter is specially used to control the max. speed of the
scanning to shift vertically from one line to the next line below it. If during the scanning, the line
space is too large or the block space is too large when scanning block figures while precise
positioning for each line or block is required, you can set the line shirt speed of scanning to a
comparatively low value. This parameter cannot be less than the jump-off speed of the
corresponding axis during the line shift and cannot be higher than the max. speed of the
corresponding axis during the line shift, if the setting is illegal, the controller will automatically
set this parameter within the range above.

Scan mode: There are two modes for your selection: the general mode and the special mode, in the
general mode, there’s no any treatment during the scan, in the special mode, light spots will be
treated. If the special mode is activated, the power of the laser should be increased and
correspondingly, the light spot percentage will be lower and the laser power attenuation will be
higher, to achieve the same depth of scanning, the laser power should be higher. The purpose to
select the special mode is to make the laser to emit beams at high power and in short period,
during deep scanning, the effect of flat bottom can
be achieved, however, if the light spots are improperly adjusted, this effect may not be achieved
and the working mode of high power and short period may influence the service life of the laser.
The default mode is the general mode.

Facula Size: When scanning the general pattern of selection, the argument is invalid, when you
select a special mode, the onset of the parameters. Control the parameters of control in 50% to

99%, respectively.



3.3.3 Home parameters

H Home para
Hore speed(mm/s) 20.000
Auto home X Yes
Auto home Y Yes
Auto home 2z No
Antn hnme L) [/g!

Home speed: This parameter determines the machine is turned back to the origin when the
speed of a larger format if the machine can be set to reset the speed is too large, but not too much.
X,Y, Z, U Auto home: The axis can be set whether should reset at boot time.

3.3.4 Go Scale parameters

H Go scale para
Go scale mode Close laser
Go scale blank({mm) 0.000

Go scale mode: Points of light to go off the border, the opening cut borders, corners three
modes.

Go scale blank: Walking frame can be based on the actual image size up and down again
about the direction of some of the white left side of the border in order to ensure complete
contains the actual graphics.

This setting is on the control panel to go with the border-related functions, while walking on
the border with the independent software.

3.3.5 Other parameters

E other
Array processing Bi-dir Array
Return position Absolute Origit

Delay before feed(s) 0.000
Dealy after feed(ms) 0

Focus depthi{mm) 5.000
Backlash X({mm) 0.000
Backlash ¥ {rmm) 0.000 =

Follow up delayi{ms) 0.000
Follow down delay{ms) 0.000

-

Array processing :Can choose a two-way array and one-way walk array. Two-way walk array:
namely array according to the order of cutting back and forth; One-way walk array: always from
one direction to another direction to array of cutting. When choose unidirectional arrays, each
array element action pattern of exactly the same, fluid movements completely consistent, but
better than two-way array is somewhat time consuming. The default choice two-way array

Delay before feed: Using the feeding device, the delay before a single feed, users can arrange the



time and the like, such as picking process.

Delay after feed: Refers to the material sent to the feed device in place, the need for stability after
a period of time for processing.

Return position: You can select the locating point and the machine origin. This parameter decides
the position, the locating point or the machine origin, where the laser head stops upon completion
of each operation.

Focus depth: Auto focus operation to find the corresponding panel.

Backlash X, Y: Used to compensate the backlash caused by the machine drive problems.

Follow up delay:

Follow down delay:

3.4 Document Management

x

gﬂgf_l(_ lQ“,tPf"L J Doc éUser lTest AI‘Transform; )

Number File Name Time(H:M:5:MS)
[ Read ] [ Process ] [ Download ]
[ Delete ] [ Cal time ] [ Upload ]
[ Delete All ]
Read

Click button Read, the software will communications with the controller, read the list of files on
the controller.
After read controller successful ,file information will be displayed in the document list.

Download

Click button Download, will pop up the file dialog , select *.rd downloaded file, then the file will
be downloaded to the controller.

If the download is successful, the document list will update.

Process
Select the file to be processed from the document list ,and click button Process

The controller will start the specified document.

Delete



Select the file you want to delete from the document list, and click button Delete
The controller will delete the specified document.
If the deletion is successful ,the document list will be updated.

Delete All
Automatically remove all file in the controller, and update the document list.

Cal time

Motherboard supports processing files towards hours worked. Select the file to calculate the
work hours worked and click the button. Calculation to be completed, the control panel will be
prompted to complete the calculation. And then point to read button shown in the list, calculated
from the working hours.

In addition, when the document processing operation performed, the hours information will
also be covered by the actual processing work.

uploading

On the main board of the selected from read offline files, and saved to the computer.

Chapter 4 Processing Output

x

Laser work Processing control
[ Start J [ Pause/Continue H Stop ‘1/
[

saveToUFile || UFieOutput || Download |

(V| Path optimize
("] output select graphics

7 Search device
Device

| -

USB:Auto

Position: Current positic ¥

4.1 Search Device

Link device in two different ways: USB and network.But through some equipment port

button on the pop up dialog box, set connection mode and choose connection port.



Q@) USB: Auto v] [ Search ]
) Web: Default Search
DefaultIP: 192 , 168 . 1 . 100

[ x|

If the computer only connected one device, you can set to Auto. The software will automatically

search the device.

If the computer connected many devices, then first of all you need to click [Find com] .

After search, the connected devices will all add to the drop-down list.

What you need to do is select the specified device.

Network: if the computer is connected only a laser equipment, which can be directly in the default
IP address to enter in connected device IP.

When the computer connection has many sets of laser equipment, and USB operation is similar.
Search at present already connected device, and choose from the drop-down list corresponding IP
address machine.

4.2 Layer processing

First, in the menu [Handle]->[Path optimize] check “according to layer order”, then click
“OK” to exit.

Layer reorder: Click button Up, Down can change the order of layers, or direct the mouse to
drag the layer to the specified location.

Here, you must check the “Path optimize” option.

4.3 Position

Setting the laser head back location after processing completed.(Current position . Original
anchor. Machine Zero.

Current Position : Laser head back to the position before processing.

Original anchor : Laser head back to the last anchor ,the anchor may set at panel.

Machine zero : Laser head back to the zero of the machine.

4.4 Go Scale, Cut Scale

For Example Go Scale, As the following figure shown, the actual graphic is round, and the red
rectangle outside the circle is the smallest rectangle, click button Go Scale, laser head will run
once along the rectangular path.



For Example Cut Scale, As the following figure shown, the actual graphic is round, and the red
rectangle outside the circle is the smallest rectangle, click button Cut Scale, laser head will be cut
along the rectangle.

4.5 Start. Pause. Stop. Save To UFile. UFile Output. Download

Start: Output the current graphic to the machine for processing.

Pause\Continue: Click Pause, will stop the processing work, click the button again to Continue
Stop: Stop the current processing work

Save To UFile:

Save current file as RD format, using for offline processing ( Can be copied to other memory board
for full offline operation).

UFile Output:

Output the offline file (RD format)

After save offline file, click Ufile Output to select rd file to processing.

Download:

Download the file to the memory of the controller , then user can start the file through the machine
panel.

4.6 Output select graphics

After check Output select graphics, then only output the selected part, rather than not output the
part not selected.

4.7 Path optimize

After check Path Optimize, then automatically perform the path optimize before the output.
If has done the Path optimize or not need optimize, then not check Path Optimize can reduce

waiting time.



4.8 Test

x

{Work ]Ou‘t_p_ut ] Doc ]User FT;;t {Transform\__

[ Current Position ] X=?
Y=?
Z=?
Axis Move
Offset(mm): 10]
Y+

— Speed(mm/s): 50

Home Power(%): 0

["]Move from origin
Y- ("] 1f Light

[ Previous work time ] 0H:0M:0S:0MS

Axis control, can only control one axis each time. You can set the information for axis move,
including move length. speed. laser on-off and laser power.

If you check “Move from origin”, then the offset you set means the offset to machine zero.

If you not check move from origin, then the offset means the offset to the current position.

The X-axis, for example, assuming the current position is 100mm, such as the step distance is set
to 10mm, then the exercise once, the new location will be 110mm, such as the check moves from
the origin, movement time, the new location will be 10mm, and repeated Movement, location will
no longer change.

Note: According to the provisions of the controller, the absolute position is no negative in the
whole breadth. If you check the Move From Origin, and set the offset value negative, then the

machine will hit limiter.



4.9 Output Setting

x

[Work | Output [poc[user [ Test [ Transform|

["]Enable rotate engrave

Circle pulse: | 1000

Diameter(mm): |20 T

|| Enable feeding
Feeding 0 Distance(mm): | 500

["] Auto block
Block repay: |0.000

Angle repay: |0.0000

|| Backlash reapy optim

[T]Enable offset of Laser2

X: |0 Y: |0

4.9.1 Rotating sculpture

[ Enable rotate engrave): After enable engraving, the actual precision of Y-axis will be based on
diameter and step per rotate to auto match the setting of pulse precision of Y-axis. In addition, the
work area in the main interface will also change.

[ Diameter): The diameter size of the parts.

[ Step per rotate]: The number of pulse corresponds to the workpiece rotate one week.

[ speed 1 : testthe speed of work.

The function is to facilitate the users to replace parts, and different size of the workpiece
when the workpiece is not very different before use. When the relatively large difference in size of
the workpiece, it is recommended to use directly modify the motor step approach to
implementation.

Rotary engraving is only when using the rotation axis to replace the Y-axis use.

4.9.2 Feed Setting

To use the feed, must first enable the feed.
After set feeding parameters, the shaft will be feeding a feeding length, and repeat the process ,
until the times of processing reach to number of feeding.

If the machine is not equipped with feeding devices, in general, enable the feed ban.



4.9.3 Optimization of Backlash Compensation

When the machine there is space (such as dislocation of the seal cutting graphics), can be
checked.

4.9.4 Optical 2 migration

In need laser collaborative work, complete the same graphics processing occasions, usually,
to use the optical 1 to define the graphics location, then if the optical 2 can accurately with the
optical 1, will need to specify the optical 2 relative to the optical 1 offset.

This generally used in two power different laser tubes of machine, because two of laser tube
power different, cause different functions.

If some machines equipped with two different power of laser tube, a responsible for cutting, a

responsible for sculpture.

4.10 Layer Settings

x

W‘iork "Q_ugut l Doc l User l Test l Transformi

Layer Mode Speed Power Qutput
I 100.0 300 Yes
B 100.0 300 Yes
B 100.0 300 Yes
B 100.0 300 Yes
e cut 100.0  30.0 Yes
B 100.0 300 Yes

[ Up J [ Down
Line/column setup
Num space Dislocation
X: |1 0.000 0.000
o
Y: 1 0.000 0.000 aoa
Virtual array ] [ Bestrew... }

4.10.1 Ranks se

For convenient to set in machining graphics processing on the array.
X numbers and Y numbers, which was the array of columns and rows.
X intervals and Y interval, respectively is array of the column spacing and line spacing.

Layer: Software use layer to distinguish processing graphics parameters of different layers.

-1

.The X interval is said and Y representing between interval graphics margins.



If hope X interval and Y interval which between is representative of array center of the graphics

Adjust the X, Y interval between enable graphic layout more closely, can click drawing area, make

spacing can switch to

graphics in the selected state, and then through the keyboard of the up and down or so key to
adjust, and rolling the mouse can be displayed scaling, make the spacing of the adjustment process
more precise.

[ Bestrewing breadth ] :According to the size of the wide and the current user Settings ranks
spacing, to determine how much can output the most listed (i.e. X number) how many lines (i.e., Y
number). Click on the button [ Bestrewing breadth] , pop-up interface as shown in figure

Bestrewing breadth |t

X breadth(mm): FE

¥ braddth(mm): 800

[ Ok ] [ Cancel

According to determine the button, the software can automatically calculate the entire width of
the ranks of the arrangement number.
[ dislocation ] : for some graphics, in arrangement, the dislocation arrangement, can make the

arrangement more compact.

-~

[ Mirror 1 : object in horizontal or vertical direction to reverse it
[ The application to copy 1 in good array, chosen to copy graphics, some application to copy,
already can duplicate array graphics.

In the layer list to edit the double click inside layer, namely will pop up layer parameter
dialog box.

The left article color, representatives of the current graphics layer, choose different color, can
be in already switch between different layer, one-time modified multiple layers of parameters.

The layer parameters is divided into two parts: public layer parameters and turn a layer
parameters.Public layer parameters is to point to no matter how the layer processing type, all
effective layer parameters;

Proprietary layer parameters is to point to the layer of processing type change of the
corresponding parameters will also be changing.



4.10.2 Laser Scan Parameters Setting

ever: |

Is Output: | Yes >
Speed(mm/s): 100 ["| Default
If Blowing: |Yes v

Processing Mode: | Cut v | Advance...

Min Power(%) Max Power(%)
Laser1: 30 30 [7] Default

Laser2: 30 30

Laser:Software to distinguish between different layers of the graphics processing technology
parameters. For scanning processing methods, more are in the same layer bitmaps, and whole as a
picture output, if hope each bitmap single output, it can be a graph respectively placed in different
layer can.

Is Output:Have two options: yes and no. Choice is, the corresponding layer will output
processing; Choose no, won't output processing.

Speed:The corresponding processing method of processing speed.

For cutting processing is concerned, the slower, processing the better, the more smooth track;
The faster the processing results, the worse the trajectory smooth;

To scan for processing, the slower, under the same energy scanning depth, deep and scanning
trace the thick, scanning the resolution also reduced.

The faster the same energy the shallow depth of the scanning, details distortion increase.
To fix for processing, the main change is empty the speed of the move.
If, check the "default", the actual speed by panel set up to speed.

If Blowing:f the machine external fan, and fan has enabled, then if choose "is", then this layer
data processing, will open the fan, otherwise, will not open the fan. If you do not make can fan, no
matter choose "yes" or "no", are meaningless.

Processing methods: says the method of processing corresponding layer;

If the currently selected is vector layer (i.e. color layer), it includes three choices: laser
scanning, laser cutting, laser rabis;

If the currently selected is a tutu layer (namely BMP layer), the only include a choice: laser
scanning.

Laser 1, laser 2: corresponding to the main board laser signals 1 and 2 of the way way laser
output. If it is only head machine, the second road laser meaningless.

The minimum power, the maximum power: the power of the values of the range of 0 to 100,
said that in the process of the strength of the laser processing; Big value, the laser is strong, is
small, the laser weak. Minimum power loss to the most power is less than or equal to.

For different processing type has a different meaning.

For cutting processing, the actual power is cutting speed and phase follow, speed, low energy
is also low, high speed is high also, so that we can guarantee the whole process of cutting energy



evenly.So the minimum power the speed of the corresponding minimum energy, the minimum
speed general is 0, but if set the speed is the minimum speed for takeoff take-off speed; The
maximum power correspond to the layer speed.

Set minimum power, and the most high power flow:

1> The minimum power and the maximum power set to the same value, synchronous
adjustment. Until all the cutting curve are already appear.

2> The maximum power unchanged, and gradually reduce the minimum power until the
energy of the heavy cutting curve at the lowest level, and all of the cohesion parts can be
processed to come out.

3>If not yet to best effect, can be the most appropriate fine-tuning high power, and repeat
step 2.

If is cut through, the minimum power loss and the maximum power no significant difference,
can be set to give the same.

To scan processing, ordinary scanning, the minimum power and the maximum power must be
consistent. Slope sculpture, minimum power loss is the power of the corresponding factors, the
most power is the power of the bottom of the corresponding.

top

Bottom

Mimimum power 1oss 1s the top for the small slant wide, detail place distinguish clearly.
Minimum power loss is too large slope not obvious.
To fix processing, the minimum power and the maximum power can be set to agree.
If checked "default", the actual power panel set by the power to determine.
Click the button "advanced", but also can be set to other layer parameters.

Other layer parameters [ S|

["]Enable pen up and down

0 mm Reac

0 mm Read
Speed:(mm/s): 100

Point
Dot interval(s) 0

[¥] Enable Laser1
[V]Enable Laser2

Extend IO output
(101

[ Ok J [ Cancel ]

[ Pen up and down ] If machines have installed the lift platform, and need to be in a different



platform height on the processing, can make can write up function.

Here the corresponding is platform write position in which high on the processing, carried the
corresponding is empty pen position before go, platform should be moved to which level in the
optical translation will not again to interfere with the process workpiece. If confirmed the optical
not and the translation of the process workpiece to interfere, don't need to set up the pen position.

Use way is:

1> Can write pen to carry.

2>Make can write position, manual control panel key mobile platform, to stay processing
graphics graphics processing plane, adjust the focal length. Then click button "read", and then
write all set up position.

3>That can carry a position, manual control panel key mobile platform, move to the optical
will not interfere with the work of the height, and through the panel key move the optical,
confirmed that won't interfere, some button "read", and then set up a position.

[ point]

Here the rabis, and is suitable for drawing tool create a point figure yuan, or from DXF file
into the spot diagram yuan. And the current layer processing methods has nothing to do, namely
whether the current layer is cutting or a scan, graphics in the spot diagram yuan has always been
to the rbi way output.

The rbi movement speed for layer speed, beating the energy for the maximum energy layer
laser.

[ The laser Enable]
When the machine is equipped with two road laser, usually, are two road and output.
But the user may through the set that laser, that its not output all the way.
[ The joint IO output ]
All the way and the layer associated 1O output, obligate function.

4.10.3 Laser scanning parameters Settings

Layer Parameter & Layer Parameter ‘L_‘@{
—
[ Load parameters from library l o [ Load parameters from library l
wver: | | |
Is Qutput: |Yes 54 Is Qutput: |Yes %
Speed(mm/s): 100 [~ Default Speed(mmfs): 100 [7] Default
If Blowing: |Yes |~ If Blowing: |Yes |~
Processing Mode: |Scan v Processing Mode: | Scan v
Min Power(%) Max Power(%) Min Power(%) Max Power(%)
Laserl: 30 30 [T pefault Laserl: 30 30 [7] Default
Laser2: 30 30 Laser2: 30 30
Negative Engrave Optimized Scan ["INegative Engrave  [] Optimized Scan
Output direct [7] independent output [7] output direct [] independent output
[7]Ramp Effect [T]Ramp Effect
Ramp Length: |0 mm Ramp Length: |0 mm
Overstriking: |Un-process | v Overstriking: |Un-process | v
Scan Mode: |X_swing hd Scan Mode: |X_swing | =
Interval(mm): 0.1 Interval(mm): 0.1
b 4 [ Ok ] [ Cancel ] ~7 [ Ok ] [ Cancel ]




On the left of the dialog box for vector scanning parameters Settings, on the right side of the
dialog box for bitmap scanning parameters Settings.
The vector data do not support the scanning the color carving, optimization scanning, direct
output.
The color carving: normally scanning, bitmap in the black spots a laser, the laser in white.
Choose the color carving, the bitmap in the white of the laser, black spots in a laser.
Optimal scanning: choose optimization will automatically adjust the users scan the scanning
interval to set up the best value, the scan best effect.
Otherwise, according to user Settings of the scanning interval scan pattern. Generally choose
"optimal scanning"
Direct output: gray scale bitmap, according to the actual graphics gray.in output, already color
deep place laser energy big, color shallow place laser
Energy is small.
Figure yuan respectively output: for vector graphics for, figure yuan respectively according to
vector diagram output is the position of the yuan relationship, which in turn will get together the
vector map carving output of yuan respectively.
If not checked figure yuan respectively output, it will be the whole vector graphics as a
whole to sculpture.
For a bitmap for, if not checked figure yuan respectively output, the system will
automatically will work with a layer of the bitmap in as a whole output.
If checked the figure yuan respectively output, the system will be in a single output bitmap.
Slope effect: the scan the edges of the figure appear slope, submit stereo effect.
Be bold font: including don't handle, scanning the font, scanning the bottom. Generally choose not
processing.
Scanning is part of the font scanning is the font, also is the Yin carving.
Note that the slope effect choice, please will be bold font choose not to deal with, or slope affected
the effects.

Font Yin carved: not to add text outside the box, scanning are text itself, as below:

Welcome

Font Yang carved: text and the outer frame, scanning is the bottom of the graphics, as below:

M




4.10.4 Laser Cut Parameters Setting

Layer Parameter @

L [ Load parameters from library ]
=
Laver: [
Is Output: Yes '
Speed(mm/s): [iog ’ [JDefault Seal cutting has not closed the graphics
If Blowing: | Yes ?v appear the case is closed, you can

x — — compensate with the seal to close, but if
Processing Mode: | Cut R4

the seal is misplaced, you can not
Min Power(%) Max Power(%) compensate, you can use 495
Laserl: |3D ‘30 'DDefauIt optimization backlash compensation to

i 1 | compensate, or to use the user parameter
el

in the Backlash compensation .
Seal: {g,ggo//m/'

Open Delay: EM Open delay

- | |

Close Delay: 'U L ;
e Close delay
Laser through mode

If checked, the light switch delay is playing

~a [ in time said.
> [ & ] [ Coneel J Otherwise, the light switch delay said is

laser movement delay.

Laserz: ‘ 30

Using the slit width compensation can compensate for the offset between the graphics and the
actual output graphics that caused by laser cutting.

It only has effective for the closed graph.

Direction: Compensation direction is set according to actual needs, such as cutting a circle, if
you want to retain the cutting down of the circle, you should set out the direction of compensation;
If you want to keep the hole should be set to compensate for the inward direction.

Sew width: it is the width of the laser.

Other cutting param - (S|

[ Enable sew compensation

Direction: | Inward

Sew width |0.1 mm

[ Ok ] [ Cancel ]




4.10.5Laser Dot Parameters Setting

Layer Parameter @

Lover: | NI

Is OQutput: Yes v
Speed(mm/s): | 100 (] Default
If Blowing:  Yes v
Processing Mode: Dot

-| (e

Min Power(%) Max Power(%)

[ Ok ] [ Cancel

]

Laser1: 30 30 [ Default _ -
; ‘ The time for emitting laser on
Laser2: |30 30 _ one dot during the process. The
/" higher the value is, the darker
Dot time: 0.1 ‘ s |
: ; The interval between the dots
Dot interval: S| /mn/'
; |
Dot length: 0 ——m—> Dot length, for cutting dash line
[[Jcenter d |
\ Only dot at center

4.11 Vendor settings

4.11.1The motor parameters

XY Z U axis parameters

Dir polarity:Change the direction of polarity can make the motor to the reverse direction.Modify

the goal is to make the shaft to the origin when reset,if reset when the axial direction away from

the origin,explain the polar axis direction set wrong,should be modified.

Limiter polarity:Used to set the limit of high and low level signal model,If moving axis reaches

the limit position ,enter a low level signal to the main board ,the limit should be set to a negative

polarity

Breadth:The longest distance between the axes can walk,according to the

actual situation of the



machine

Home offset: If the shaft can make the hard limit protection,often should set the value of
2~5mm,if set to 0,then the axes coordinate zero run to minimum,effective,has the potential to limit
such trigger error limit protection function,emergency stop the machine,if can not make the hard
limit protection,can set value is O~5mm.

Contrl mode:Double pulse and pulse+direction mode optional,depending on the of motor drive
machine actual configuration decision,general model for pulse+direction

Step length;Namely motor pulse equivalent, send a pulse to the motor, the corresponding motion axis through the
absolute distance value.Before this value is set up correctly, can let the machine cutting a large rectangular
(graphics is bigger, can make the error smaller), automatic calculation by graphic length and measuring the length
of the step motor.

Enable limit trigger:Whether used for enabling the axis of the hard limit protection function.

PWM rising edge valid:Used to set the motor drives the pulse signal is rising falling edge along the efficient
or effective, when not enabled the falling edge controller using effective;When this is enabled, use the rising along
the effective controller.

Enable Home:If machine configuration with the shaft, the shaft "reset enabled" option should be open, if not
configured the shaft, then the shaft "reset enabled" option should be banned.The meaning of this parameter is to
control the "reset" boot options in the user preferences and function keys in the "reset" the axis function, prevent
users mistakenly to reset the shaft moving that doesn't exist.

Jump-off speed:Movement speed of shaft directly start from stationary state, if the value is too big, can lead to
motor lose step, jitter, and even produce the noise and set is too small, can reduce the running speed of the
graphics.The heavier if the large inertia of moving axis (axis), can install a smaller takeoff speed, if the movement
axis of inertia smaller lighter (shaft), can be appropriately increase the rotate speed.Typical values such as 5 ~ 30
mm/s.

Max speed:The shaft can withstand maximum speed.The parameters and inertia motor drive power, motor shaft,
and gear ratio.Typical values such as 200 ~ 500 mm/s.

Max Acc:Motor shaft in the maximum acceleration and deceleration motion, acceleration set is too large, also
can lead to motor lose step, jitter, and even produce the noise and set is too small, can lead to speed up slow and
reduce the running speed of the graphics.Corresponding to the large inertia axis, such as beam of the Y axis, a
typical setting for the range of 800 ~ 3000 mm/s2, corresponding to the axis of inertia small, such as the car of the
X axis, a typical setting range is 8000 ~ 20000 mm/s2

EStop acc:Can make the hard limit protection, if the shaft, when the axial movement to the limit position, to the
shaft to stop operation for emergency stop acceleration deceleration.This value may take the maximum
acceleration of 2 ~ 3 times

Keying

Jump-off speed:Keys on the keyboard to move the axis movement starting speed, not above the shaft rotate
speed

Acc:Buttons move the axis motion acceleration value, cannot be higher than the maximum acceleration

Invert direction:

Used to control the movement of the manual button when the mobile movement axis direction.When set the right
direction of polarity parameters, if press the direction key on the operation panel, the axial direction, which buttons

can reverse.



4.11.2 Laser parameters

Laser config:Single tube/pipe is optional, according to the number of laser tube manufacturers actual
configuration Settings

Laser mode:Glass tube, radio frequency laser (don't need precombustion pulse) and radio frequency laser (need
precombustion pulse) optional

Laser attenuation. Min power. Max power. Laser freq. precombustion freq:
Precombustion pulse:For radio frequency (%) laser and precombustion pulse, frequency and precombustion
by precombustion pulse width configuration precombustion characteristics of the pulse.

Signal level:

Water protect:When can make water protection, the controller must be connected to water protection circuit,
the machine won't out of the light, if we do not make water to protect, don't pick up the water protection circuit,

the controller will not detect.

Laser frequency used by the control signal is used to set the laser pulse frequency, the glass tube, generally set to
about 20 KHZ, Radio frequency tube usually about 5 KHZ;Maximum/minimum power (%) is used to set the limits
of the laser power value, namely at runtime, users to set maximum power can not be higher than the set value of
maximum power, user Settings cannot under minimum power value for the setting of the minimum power
value;Use after a period of time, if the laser power attenuation, is by setting the attenuation coefficient to
fine-tuning of laser power, laser without attenuation, attenuation coefficient of 0.

Prompt:If single laser tube is configured, it only shows a laser parameters

4.11.3 Other vendor parameters

Machine type:For the most part should choose general engraving machine, other models for a particular model
Transmission mode:Under normal circumstances should choose "step type belt", choose other type, control
algorithm will have small change

Feed mode:A one-way/two-way optional. When for one-way feeding, do not check the coordinate, but has been
unilaterally upward; When selecting a two-way feeding, the system will check the maximum minimum coordinates,
an odd number of times to one direction, even time to another direction, first initial direction by setting the
direction of polarity to change or modify feeding the length of the positive and negative value

Broken delay:Can be set to 0 ~ 3000 ms.After power grid, the system power supply does not immediately
reduced to 0 v, during a time delay, the power set delay value should be the actual delay values are basically
identical.If the value is set, the deflection is in power to continue carving work, a second processing of graphics
and graphics or not closed before power, or too much overlap

Enable protect:If can make this, the controller must be open protection circuit is connected, otherwise the
machine will not work

Enable blower:If want to use the outlet Wind signal layer and control the fan switch, you must make to the
parameters, otherwise, the Wind signal output to other signals

Prompt:Manufacturers in the parameter configuration parameters, such as the direction of polarity, control mode,

the types of laser and laser frequency modified four parameters, it is necessary to reset the system, reset after the



completion of the changes to take effect.

Thank you for using the product of Shenzhen Rui Da Technology Co. All parts of this
note, the economic rights of the Shenzhen Rui Da Technology Co. Without our approval, no
unit or individual shall not reprint, copy or distribute the content related to this product
manual. If the product content information to change without notice.

Users who have any comments or suggestions in the process of using the instructions,

please call.

Phone: 0755-26066687 Fax: 0755-26982287
Address: Building 2-501# , Tian’An industry park, Nan you, Nanshan District, Shenzhen
City.

Website: www.rd-acs.com



http://www.rd-acs.com
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